woocommerce

升级WooCommerce 4后数据库报错降级3.93老版本的方法

今天给一客户把WooCommerce升级到4.0.1之后,数据库报错,提示>save_action(Object(ActionScheduler_Action), NULL) #1这类型的问题,通过官方论坛其他用户反馈情况来看,出现这个问题的原因是因为你的产品数量太多(通常超过1000)导致的。

升级到WooCommerce 4后数据库报错降级到3.93老版本的方法

解决的办法就是临时降级到WooCommerce 3.9.3,等待下次WooCommerce更新后测试是否解决了这个bug。

降级方法:

1、下载老版本的WooCommerce 3.9.3安装包

2、覆盖现有的WooCommerce插件文件夹的文件

3、恢复备份的数据库

参考资料:

https://wordpress.org/support/topic/can-not-update-my-database/

 

请求帮助:亲戚脑出血进ICU病房抢救,家庭负担极重,恳请您的帮助,1元2元也是一份支持,谢谢大家。

Scroll to Top