禁用WordPress特定插件通知提醒

WordPress禁用特定插件的更新提示

某些情况下,你可能并不需要某款插件检测更新,那么你可以使用下面的WordPress代码来禁用特定插件更新提示。

你只需要把下面的代码修改后加入你主题函数文件里面就可以了。安全添加代码到functions.php文件的方法:Code Snippets

//屏蔽插件更新通知 https://blog.naibabiji.com/archives/1755

function wcr_remove_update_notifications($value) {
    // 要屏蔽的插件位置 (从wp-content/plugins文件夹下)
    $plugins = array(
        'wpjam-basic/wpjam-basic.php'
    );
    
    foreach ($plugins as $key => $plugin) {
        if (empty($value->response[$plugin])) {
            continue;
        }
        
        unset($value->response[$plugin]);
    }
    
    return $value;
}

add_filter('site_transient_update_plugins', 'wcr_remove_update_notifications');

当然,保持插件最新是WordPress安全因素之一,不是特别原因,不要随意禁止更新通知哦。

版权申明
如未注明,均为奶爸笔记原创,码字不易,转载请注明出处及原文链接!
本文标题:《WordPress禁用特定插件的更新提示》
本文链接地址:https://blog.naibabiji.com/archives/1755
打赏 赞(0)
微信
支付宝
微信二维码图片

微信扫描二维码打赏

支付宝二维码图片

支付宝扫描二维码打赏

你可能感兴趣

6 thoughts on “WordPress禁用特定插件的更新提示

发表评论

电子邮件地址不会被公开。 必填项已用*标注